Incident on Telenet Connectivity

Incident Report for WEngage

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 09:35 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2026 - 23:15 CEST

Investigating

We are currently investigating an issue where Telenet connectivity is down due to a major outage at Telenet.
Posted Aug 12, 2026 - 12:17 CEST
This incident affected: Datacenter (DCO - Main, DCG - Backup, VPN Gateway) and Locations (Diegem, Hasselt, Liège, Oostende).